Sunday, January 30, 2011

Error Installing Phusion Passenger on OSX Leopard - Ruby 1.9.2

As I began to play more and more with RoR on my mac today I decided to do a few things.

  • Install Ruby 1.9.2
  • Install Phusion Passenger

By default Snow Leopard has Ruby 1.8.7 installed but I wanted to begin using the latest 1.9.2, so with a little help from Pragmatic Studio I got it done. For more read - http://pragmaticstudio.com/blog/2010/9/23/install-rails-ruby-mac.

Shortly after that I decided to install passenger so I can deploy apps on Apache an by using their instructions I kept getting the following error:

/Library/Ruby/Site/1.8/rubygems.rb:779:in `report_activate_error': Could not find RubyGem rails (>= 0) (Gem::LoadError)

Basically the steps where as follows:

  • sudo gem install passenger
  • sudo passenger-install-apache2-module

The problem was due to me trying to install on the 1.9.2 build which I installed and manage using rvm and for that you need to do the following:

  • rvmsudo passenger-install-apache2-module

I can't take full credit as I found the answer here: Article on stackoverflow

Up next - applying changes to my httpd.conf and seeing if it works :-)

Post a Comment